Anthem (2019)

officialthread

#161

Yeah, apparently some of the issues affected other EA online titles as well so it must have been an issue with authentication and profile systems


#162

However, that’s purely an EA issue. Guess we’ll see what happens over the next few weeks


#163

Controls still feel very console not pc, I cant seem to get the flight right, it makes me very ill.

also I could redo the first part of the manifold mission and that was it - 4 times. . . . I couldnt select the follow up.


#164

Have to agree with you there. I really hope they change the keyboard & mouse controls to not have stuff like push and hold to select options and exit menus.

Also little things (but indicative of the larger problem), like having “Exit Game” under Settings. Clearly shoe-horned in there because consoles don’t need an Exit Game option.

You might have run into the same issue as GotChange. He accidentally used the Quick Play option instead of selecting a mission. I think unless you physically click on the map, pressing F results in Quick Play. As soon as you click on the map, Quick Play is turned off.


#165

I cut together a video of my play-through of the story quest in the demo for anyone who wants to check it out.

Looks like YouTube is still processing it, so HD is not yet available :frowning:

UPDATE: It is now available in its full 1080p 60fps glory!


#166

#167

I’d like a try please if it’s still available. Till when when do we have and what do I need? Is it just for this weekend?


#168

It is just this weekend. Please send me a friend invite on Origin. I should be SIGSTART on there, and have an icon of a big, mean, almost Briareos-looking Geth.


#169

Thats one big Geth. Thanks man, added you. Luckily I have a faster line now. So I can download overnight.


#170

Seems nothing was learned from the swtor launch regarding server issues…

PCgamer isn’t impressed :
https://www.pcgamer.com/anthems-vip-demo-isnt-giving-me-much-faith-in-a-smooth-launch/

Doesn’t seem to be well optimized either from pcgamers results:


#171

Tried as I might, I couldn’t play. When loading into a mission, it would load to around 90% and freeze. Reading online the solution was to quit the game, restart and it would allow you to continue again. I did that, but then it gave a server error and popped me back in the “tower” at the table where the demo begins. After going through that twice, I decided to shelve the game. The first person controls felt laggy as hell and the character didn’t walk or even stroll - it feels like an ant pushing him around. It REALLY needs to be fixed.


#172

Dude, that was the only option my brother and I got. We couldnt no matter what do anything else - I tried clicking on the missions, nothing happened, clicking on the map itself did nothing.

All I got was that quickplay. I even tried doing it private mode and no luck


#173

So far, from all the reading I have been doing about this demo, it seems to be an all around demo of how not to port a console to PC game. There also has been a lot of comments from Bioware about how much different the release version is from the demo.

Will have to wait and see for the 15th. I am contemplating taking a day off to play but will only do so a week after release, it probably will take me a week or so to download the probably 100gig or so. Been bitten in the a$$ too many times by release week blues to make the same mistake again.


#174

So I got a key from @SIGSTART and it said I already had access to the demo. When I downloaded and opened the game it said I didn’t have access. Spoke to EA Support on Chat and they sorted me out quickly. Just incase anybody else have this issue.


#175

WTF infinite loading time.


#176

That seems to happen to everyone I’ve spoken to the first few times they tried to load into an expedition.

Alt+F4 the game, check Task Manager to make sure It’s properly killed (also check under the Origin process tree), and relaunch.

Sadly it seems to take about two attempts for you to eventually load in. I’ve had no problems since Saturday morning.

EDIT: I might also be seeing patterns where there are none. This could be completely random.

EDIT 2: Here’s a link to EA Support’s post about it:


#177

Bioware is going for transparency with Anthem. (Which is also something Digital Extremes did with Warframe, but this is a little bit like comparing South Park to The Simpsons. I digress.)

Here’s a blog post about the issues:

This is the important part based on what we’ve been discussing regarding server capacity:

… I want to dispel one comment we’ve seen: that we under-planned for server capacity. To ensure stability, we intended to manage our servers to match the player population as it grew. Overall, we had excess capacity prepared for population increases, and continue to do so. That said, what’s important is that all parts of the game work as designed to meet players’ needs, and that did not happen in the opening hours.

Sadly, they don’t address the post that’s doing the rounds which claims that Anthem was effectively DDoSing EA’s whole infrastructure:

So I’m the guy on GAF who did the packet captures of No Man’s Sky at launch to prove it had no multiplayer.

I did packet capture on Anthem and it has the opposite problem. If it fails to connect it floods their servers trying to reconnect. They’ve created a condition where they’re DDoS themselves, and EA.

Not the first time I’ve heard of something like this happening, but also haven’t been able to verify it as I didn’t run my own Wireshark capture when the servers were overloaded.

Whataver Bioware and/or EA have done since Friday night improved server availability, though, and they did that without patching the demo as far as I can tell.


#178

Makes sense, big up to Bioware for actually explaining


#179

I managed to get some me time late last night, and got to log-in and play for a little over 2 hours without any technical issues, infinite loading screens or other weird problems at all. I had read a bunch of suggestions throughout the day to try and avoid problems though. Things I did before playing:

  • Started the Origin client as Administrator
  • Turned off Origin overlay in the client (“Origin In-Game” in the Origin > Application Settings menu)
  • Once connected, immediately went to Graphics Options to turn off Motion Blur and Depth of Field, and turned V-Sync on. Also confirmed that the game would run in Full Screen mode.

That was pretty much it. Ran the game for 2+ hours, at least an hour of which was on a mission, without issues. Even had it streaming to Mixer in the background at 720p/60fps and noticed no strain or lag on my machine at all. (I did try the first mission in “Private” mode so didn’t have anyone one else in my session that may have been a factor in keeping lag and stutter down.)

I decided to go solo for my first time as I didn’t want to potentially add to someone’s issues after they’d possibly spent hours just getting into the game with my inept noobness. Judging on my resulting play, not a bad decision :slight_smile:

As far as my gameplay itself was concerned - and keeping in mind that I have never played a single Destiny or Warframe session in my life, and am an absolute FPS idiot gamer - I didn’t think it was too bad. Despite not working out half the keyboard controls and frequently hitting the wrong key at the wrong time, regularly flying into rock-faces and trees, and wasting all my ammo trying to take out Dominion soldiers from too far away, I actually enjoyed myself.

I did make mouse sensitivity adjustments for flying (dropped both the last two options for flying and swimming to zero). I never got to swim anywhere, but my flying wasn’t too bad, and I think after a little more practice it could be a lot more enjoyable. Again, it may well be my lack of experience with this sort of game impacting my expectation levels, but I honestly didn’t think flying was the complete shite experience I’ve seen it described as.

Here’s a quick clip from my stream VOD file to see what a general low-impact area ran like for me:

Wasted way too much time trying to clear enemies at the first camp before I realized that their spawn portal wouldn’t close until I’d triggered the signal :man_facepalming:. Then spent ages wandering around getting sidetracked by an outlaw base and a bunch of weird scorpion-spider looking things. By the time I eventually got to the second enemy camp, I was almost out of ammo, some fire-shooting demon was setting me on ablaze from seemingly miles away, and I realised why the games initial suggestion to try the mission with a mate was made. There was no way I was going to manage that camp by myself. From there I managed to exit out to the main menu, saw a mission about “you have an active mission, would you like to rejoin it?”, and exit out the game without it crashing or freezing on me.

Loved the lightning and details in the Fort Tarsis environments:

And also wasted a load of my limited time playing around with the skin customiser:

If time allows, I do want to try get back into it for another hour or so. Assuming the Demo ends at 7PM tonight? Hopefully the server, log in, and loading issues are resolved in time for their Open Demo weekend.


#180

Nope, gave it another shot today. Still couldn’t get past the infinite loading screen issue (as per my previous post). So I uninstalled it.