Star Citizen

discussion
officialthread

#303

Multiplayer is amazing now thanks to how fluid the latest patch feels. My brother and I had a really good time taking out FPS AI the other night.


#304

So has anyone had a chance to try the free fly? I’ve not had much play time. I did however add a few new tutorial vids, including basic flight, using the star map, and quantum travel.


#305

I have given it a go - so far I have left Port Olisar and flown to Hurston a number of times - because I had to logout before being able to dock somewhere. I tried landing at the Teasa Spaceport to have it repeatedly tell me that all the landing pads were busy - so I haven’t been able to try out any of the new ships.

Hopefully I’ll get a chance to give it a proper go.


#306

There are too few pads at Lorville currently; when the business district opens we’ll get a bunch more. I suggest you land at one of the gates and take a train to Teasa. Once you’ve rented a ship at the exhibition, you can spawn it from anywhere.


#307

Found this.


#308

I need to go look at that!


#309

Would it still be there though?
Also I managed to get there, my gosh the trip is long even in Quantum travel haha. I’ll see if I can get there again. Had a look at the 600i it really is amazing, wow.
Also the Cutlass black is actually pretty big lol.


#310

The exhibition resets daily at 18:00 our time. Aegis ships should be on display until then.


#311

Crud I’m gonna miss out. It’s my Grandmother’s 80th at 18:00 :rofl:


#312

Gran is way more important. Enjoy!


#313

The moons of Hurston… Bleak and desolate rocks, the lot of them. Magda is my personal favourite. Arial actually does look like it’s made from cheese.


#314

Blade Runner: 2948


#315

Reminds me of the ‘Machine World’ in The Matrix.


#316

It kind of does!


#317

What kind of frames are you getting in Lorville? It looked pretty smooth.

I’ve identified my CPU as the bottleneck in the busy areas such as Lorville, I guess my trusty i5 6600K is starting to show it’s age now. What CPU do you have?


#318

Lorville needs lots of optimization; I would not take take it as a performance benchmark at this point. Have a look at your frames in Port Olisar and away from the busy areas.

I use a Ryzen 5 1600 with a 3.8GHz all-core overclock when gaming. It performs quite well with the game.

Have you taken a look at the performance telemetry yet?

https://robertsspaceindustries.com/telemetry


#319

Ok cool.

Wow that performance telemetry page is a very cool feature!


#320

Indeed. It helps you plot exactly where your PC fits into the bigger picture.

Mine currently sits in the 40-49 fps average bracket, but most of the time I experience much higher FPS than that. Subjectively, at least.


#321

So I’ve had a few opportunities to spend some time with SC this week, and overall, I’m well stoked by the experience. Probably about 6-odd hours in total, zero crashes. Performance in general has been really good on my Ryzen 1700, GTX 1070, 32GB RAM machine. A handful of stutters here and there, a low fps of 20-odd in Lorville, but no major issues. My fps averaged at around 50fps in most cases (and that’s with VSync on in an effort to lower the load on the GPU so that I’d have a little spare for streaming.)

Here’s me on the telemetry tool:

There are still a bunch of bugs and glitches throughout. Missions seem especially borked at the moment. Tried a couple of the older PI and Comms Array missions with limited success. Combined with a hugely frustrating inability to get my mobiGlas working properly especially when in a cockpit, I struggled to follow the mission prompts and updates.

The issues with getting the mobiGlas to function properly also made navigation with Star Map pretty much impossible. Landed up mostly using QT to select a destination and then just heading off in that direction. Fairly aimless, but still fun discovering places I’ve never seen before.

Took my Freelancer out for the first time to try and get from Port Olisar to Lorville (figured that if I get lost or something that I’d at least have a ship with a bed to log out from and get back to again). Managed to find a couple of Rest Stops along the way and tested the cargo buying tools. They both only had scrap available to buy, but the system worked fine. In fact, got a bit of a thrill after making the purchases to get back to the ship and see all the crates neatly packed into the cargo area, even if it was only scrap.

I decided to stop off on Ita (?) on the way to Hurston. Found a small mining outpost and touched down successfully on a landing pad there. Went in search of a cargo terminal (with the idea that maybe this lonely outpost would have a use for a bunch of top quality rest stop scrap!) only to discover that the Freelancer I’d arrived in 5 minutes earlier was not listed at all. A quick glance out of the window at the empty landing pad confirmed the suspicion that my ship had vanished into the ether. Together with my cargo of (not so) valuable scrap. And all the credits I’d spent buying the scrap in the first place. :frowning_face:

Eventually found a Ship Retrieval Terminal in one of the other outpost buildings and saw my Freelancers’ location listed with a vague “Stanton”. The terminal kept telling me that the ship I tried spawning (a Sabre) was “Too large for the available landing pad”. It did allow me to spawn my Dragonfly, but there was no way I was going to get from there to Hurston and Lorville on a Dragonfly, so I decided to suicide and resigned myself to try getting to Lorville another time.

My next session had me taking my Sabre on a straight shot from Olisar to Lorville, with no side quests to confuse the system along the way. It took a while in QT but I did manage to get to Hurston and then down to Lorville without any problems. It was the first time I’d seen Lorville in the daylight, so I decided to go have a look for those mythical Perimeter Gates that I heard about. (Mainly because I really wanted to take the longer train ride into the city :slight_smile: ) Half an hour of circling the city a number of times and having the No-Fly barrier scream at me almost constantly and I gave up. I know I’m missing something really obvious, but I simply could not find any one of the gates, never mind six of them. Ended up landing successfully at Teasa Spaceport and, after a quick visit to the Expo to see the Drake ships on display, I logged out.

10/10 want to go back into the game ASAP to try mining.


#322

Yeah, this is a major problem for me as well. Not sure why it’s so bad right now. You might try coming to a complete stop, that sometimes works.

Pro tip for landing at outposts: never use the pads! Set down on open ground next to the outpost. The cargo terminal will still be able to transact with your ship.

I suggest you try the handy metro rail system; there are trains going to the gates. :smiley:

Glad to hear you had fun though! I’ve had very little playtime the last few days. Any suggestions on additional tutorial videos?